Setup for Debug logging - UM client

The objective when generating debug logs for an issue is to get complete logs, that capture the issue at hand, while minimizing the 'noise' in the logs from lines not related to the actual issue.

The following procedure will walk you through the process of generating such a log set:
1) On the workstation running the client, in the User Management Program Group, find Log Viewer and run it as an Admininstrator
image.png 96.87 KB

2) When Log Viewer opens, under the File menu, select Clear All Logs. 
image.png 18.46 KB

3) You can leave Log Viewer open.
4) Next, again in the User Manaement Program group, Run Configuration.
image.png 8.14 KB

5) Select the Stopped radio button, when the service stops, select Full from the drop down menu for Logging Type

image.png 8.95 KB

6) Select the Started Radio Button to restart the service.
7) Recreate the issue, twice. 
8) Go back to Log Viewer, under the File menu, select Refresh List of Log Files.
image.png 20.71 KB

9) Under the Tools menu, select Zip Log Files, provide a name, and attach the resulting zip file to your email reply, or post in the your case in the Community Portal.
image.png 26.54 KB

10) In the event you encounter an error during this process, take a screenshot of the error, then continue with the rest of the procedure and add the screenshot to the zip of log files.
How did we do with this article?