The application does not register successfully on the device

Please check that the firmware on the device is not older than December 2014 and support the OXPd v1.7.1 SDK. Do also check that you are using the correct password for the device.
How did we do with this article?